Проблемы с EV3

Раздел для обсуждения наборов серии Technic, разных механизмов и конструкций. А также роботов на основе Mindstorms.

Модераторы: Snake, SteelGhost, AmbiDexter

Автор
Сообщение
yarkaa
Аватара пользователя
Сообщения: 8

Проблемы с EV3

#1 Сообщение yarkaa » Вс апр 06, 2014 4:52 pm

Друзья.

Может кто поможет со следующей проблемой.

При подключении блока EV3 к компьютеру программа (стандартная от ЛЕГО установленная для программирования EV3) предложила обновить блок, после нажатия загрузить, через некоторое время надпись на экране - Программа не может обновить - нужна ручная перезагрузка. Все дальнейшие перезагрузки блока (нажать на те клавиши, отпустить эти клавиши) ни к чему не привели. Блок постоянное горит красным цветом и надпись на нем "загрузка" и в течении 30 минути далее ничего не происходит.
Что делать? Может кто подскажет. А Сервисные мастерские по Лего EV3 у нас есть? Куда обращаться?

Спасибо все кто откликнется, да и не откликнется тоже.

opTEAMist
Аватара пользователя
Сообщения: 66

Re: Проблемы с EV3

#2 Сообщение opTEAMist » Вс апр 06, 2014 11:59 pm

Коллега, я перечитал Ваш пост несколько раз - эмоции через край, а по сути нифига не понятно, извините.

Из того, что понял - возникла проблема при попытке обновления прошивки "кирпича" с ver. 1.00 до ver. 1.03. Что ж, такие проблемы возникают сплошь и рядом - первая версия прошивки глючная.

Никуда бежать не надо. Вот здесь подробно описано, как обновить прошивку "кирпича", и как ПРАВИЛЬНО перезагрузить "кирпич" (описанный в мануале "обычный" способ перезагрузки здесь не поможет) и ПРАВИЛЬНО обновиться вручную, если в процессе автоматического обновления возникла ошибка. Переводчик Гугл в помощь.

rm8
Обозреватель
Аватара пользователя
Сообщения: 735
Контактная информация:

Re: Проблемы с EV3

#3 Сообщение rm8 » Пн апр 07, 2014 12:49 am

opTEAMist писал(а):Коллега, я перечитал Ваш пост несколько раз - эмоции через край, а по сути нифига не понятно, извините.

Из того, что понял - возникла проблема при попытке обновления прошивки "кирпича" с ver. 1.00 до ver. 1.03. Что ж, такие проблемы возникают сплошь и рядом - первая версия прошивки глючная.

Никуда бежать не надо. Вот здесь подробно описано, как обновить прошивку "кирпича", и как ПРАВИЛЬНО перезагрузить "кирпич" (описанный в мануале "обычный" способ перезагрузки здесь не поможет) и ПРАВИЛЬНО обновиться вручную, если в процессе автоматического обновления возникла ошибка. Переводчик Гугл в помощь.


Изображение

Подтверждаю. Восстановил уже два кирпича EV3 8)

lizard
Сообщения: 1

Re: Проблемы с EV3

#4 Сообщение lizard » Пт ноя 07, 2014 11:57 pm

Добрый день.
Купила ребенку EV3, до сегодняшнего дня всё было хорошо, сын делала проекты, потом загружал их на модуль ev3, робот начинал работать, сын счастлив.
Но сегодня возникла следующая проблема, при попытке загрузить очередной проект на модуль ev3 выскакивает сообщение "недопустимое имя проекта", меняли имя и так и эдак, забивали больше чем 32 символа,всё успешно сохраняется, но как только пытается перекачать на модуль опять выдается "недопустимое имя проекта"
Подскажите что произошло?

pavlo
Сообщения: 858

Проблема с прошивкой EV3

#5 Сообщение pavlo » Пн дек 26, 2016 9:50 am

Подарили мы сыну робота на день рождения, сам я был в отъезде, но заранее (еще полгода назад) закачал в модуль некоторые программы и уехал в командировку.
Сын в течение месяца собирал различные модели и все работало. Когда я вернулся решили собрать гитару, и, как дело дошло до заливки программы, я подключил модуль к компу и увидел сообщение о том, что есть свежая версия прошивки. При попытке обновить прошивку процесс остановился на 50%, подождав минут 15 я попробовал повторить но безуспешно. Выключить модуль после этого можно было только выниманием батареи. Загружаться в обычном режиме он тоже отказался... :cry:
Весь вечер штудировал интернет, а утром решил все делать правильно (произвел операции в следующей последовательности):
- купил новые батарейки (до этого были изрядно подсаженые),
- включил компьютер и запустил программу LEGO MINDSTORMS EV3 Home Edition,
- подключил USB провод непосредственно к разъему в материнке (до этого использовал USB на передней панели компьютера),
- достал модуль из модели и отсоединил от него все провода моторов и датчиков (в первый раз перепрошивал модуль не вынимая из модели),
- изъял из модуля все (6) старые батарейки,
- установил в модуль пять (5!!!) новых батареек,
- нажал центральную и правую кнопки на модуле и установил последнюю (шестую) батарейку, модуль включился в режиме Updating, после этого кнопки отпустил,
- подключил USB кабель к разъему модуля,
- выбрал в меню Инструменты программы LEGO MINDSTORMS EV3 Home Edition пункт Обновление встроенного меню
- в появившемся окне нажал кнопку Обновить встроенное ПО,
- наблюдал как весело без остановок заполняется шкала информирующая о прохождении обновления, и как модуль сам автоматически перезагружается.
ВСЕ!!! Перепрошился легко и с первого раза! :D :D :D

Не знаю что конкретно повлияло, но скорее всего то, что батарейки были довольно сильно подсажены.


Вернуться в «Технодром»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 9 гостей